Costruite da soli la vostra PirateBox

Questo post è la traduzione italiana delle istruzioni pubblicate nel sito di David Darts, l’inventore della PirateBox.

Puoi costruirti una PirateBox con meno di 50 euro. Per maggiori informazioni ed aiuto vai al forum della PirateBox. Per avere maggiori informazioni  sul progetto (in inglese) puoi leggere qui e qui.

PirateBox

Materiale necessario

  • TP-Link MR3020 (Amazon.it) o TP-Link TL-WR703N

  • Chiavetta USB (formattata FAT32 con un’unica partizione)

  • Cavo ethernet

  • Batteria 5V/USB (facoltativa)

Preinstallazione

Il seguente tutorial è stato creato su un Mac con OSX 10.8. Tuttavia, queste istruzioni vanno bene anche per Linux o Windows (richiede PuTTY ).

1. Prima scarica una copia personalizzata di OpenWrt per l’MR3020 (modificato da Matthias Strubel che include tutti i moduli del kernel necessari). Vedi questo thread sul forum per ulteriori informazioni. Per il WR703N, scarica il firmware OpenWrt

2. Imposta l’interruttore situato accanto alla porta LAN / WAN in modalità WISP

3. Spegni il wireless del computer portatile (in OSX, fai clic sull’icona wifi e seleziona “Turn Wi-Fi Off”)

4. Collega il router via cavo Ethernet al computer e apri un browser web alla pagina http://192.168.0.254 (per l’MR3020) oppure http://192.168.1.1 (per la WR703N)

5. Immetti il nome utente e la password di default (admin e admin)

6. Passa  a System Tools > Firmware Upgrade e seleziona il firmware OpenWRT

(Nota:. Il testo del firmware WR703N è in cinese, per flashare OpenWrt dall’interfaccia web, seleziona l’ultima voce del menu a sinistra, e poi la terza voce del sottomenu. Maggiori info in questo post ).

7. Dopo aver completato l’aggiornamento, il sistema si riavvierà

8. Collegati in Telnet al dispositivo:

telnet 192.168.1.1

9. Utilizza il comando passwd per impostare la password di accesso – questo permetterà l’uso di SSH.:

passwd

10. Modifica il file network con  vi (vi elenco comandi ):

NOTA: Le seguenti istruzioni presuppongono che l’indirizzo IP del gateway del router (router di casa) sia 192.168.2.1. Se il tuo router gateway è diverso da questo, è necessario modificare il file network di conseguenza. Tieni a mente che il tuo (PirateBox) router OpenWrt non dovrebbe avere lo stesso indirizzo del gateway del router, anche se avrà bisogno di essere sulla stessa sottorete per accedere e scaricare i file da Internet.

vi / etc / config / network

Il file modificato dovrebbe essere come questo:

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option ifname ‘eth0’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.2.111’
option netmask ‘255.255.255.0’
option gateway ‘192.168.2.1’
list dns ‘192.168.2.1’
list dns ‘8.8.8.8’

11. Togli l’alimentazione al router.

12. Accendi  il wireless del portatile (per OSX, fare clic sull’icona wifi e selezionare “Turn Wi-Fi On”)

13. Collega l’MR3020 (o WR703N) al gateway del router (ad esempio, il router della rete domestica) con un cavo ethernet e collega nuovamente l’alimentazione. Aspetta un paio di minuti fino a quando il  router si avvia. Con il computer collegato alla rete di casa, prova a connetterti al router via ssh (nota: utilizza l’ “ipaddr” assegnato al punto 9):

ssh root@192.168.2.111

14. Fai un ping  a Google per verificare  che le impostazioni del firewall siano corrette:

ping google.com

15 Aggiungi  il supporto USB per OpenWrt installando e attivando i seguenti pacchetti. (Nota: questo passaggio non è necessario se hai utilizzato l’immagine personalizzata di OpenWrt dal punto 1):

opkg update
opkg install kmod-usb-uhci
insmod usbcore ## may return: file exists
insmod uhci
opkg install kmod-usb-ohci ## may return: up to date.
insmod usb-ohci

Installare la PirateBox

Adesso devi installare  la PirateBox sul router.

1. Collega l’unità USB (formattata in FAT32 con una sola partizione) alla porta USB.

2. Installa il pacchetto mkPirateBox dando i seguenti comandi.

cd /tmp
opkg update && opkg install http://piratebox.aod-rpg.de/piratebox_0.6.3_all.ipk

3. Facoltativo: installa la Kareha Image Board :

/opt/piratebox/bin/timesave.sh /opt/piratebox/conf/piratebox.conf install
/opt/piratebox/bin/install_piratebox.sh /opt/piratebox/conf/piratebox.conf imageboard

Successivamente, modifica il file di configurazione della Kareha Image Boardi per cambiare il nome utente e la password (ADMIN_PASS e SECRET) admin:

vi /opt/piratebox/www/board/config.pl

4. Una volta che l’installazione è completata, scollega il cavo ethernet e scollega l’alimentazione per almeno 10 secondi.

5. Riavvia il dispositivo e collegati alla rete “PirateBox – Share -Freely” . Apri una pagina web e dovresti essere reindirizzato al menu PirateBox.

6. Inizia a condividere i file e a chattare!

piratebox su iphone

Aggiornamento

Per eseguire l’aggiornamento da una versione precedente di PirateBox, leggi  questo tutorial sul forum PirateBox .

Ripristino

Per il TL-WR703N, utilizza queste istruzioni dal wiki di OpenWrt per entrare in modalità failsafe. Vedi anche il video di Matthias Strubel.

Maggiori informazioni su come costruire una porta seriale (utile per il recupero di un router “bricked”) per il TL-WR703N sul wiki di TheVillageTelco .

Forum PirateBox

Per favore  invia domande, scoperte, idee e soluzioni al  Forum PirateBox .

Testo originale:

http://daviddarts.com/piratebox-diy-openwrt/?title=PirateBox_DIY_OpenWrt

Advertisements

2 pensieri su “Costruite da soli la vostra PirateBox

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...